Tiledef errors

When switching levels that use the two different styles of tile layouts (such as entering oldworld style from a new world style), massive graphicsl glitches occur. Update Level fixes this, and then the level loads properly for the rest of the time you are connected. Is there a way to stop this from happening?

Marduk’s world map uses
addtiledef worldmaptiles.png,levelname,1;

But only the world map uses NW style currently. When entering a region from the world map, it switches back to old world style, or
addtiledef pics1.png,levename,0;

When entering the world map, graphics load just fine. OW switches to NW without any issue. But when entering a region that uses OW, the switch back causes the tiles not to load properly the first time.

This happens offline too, so I know it isn’t a Gserver issue, but Iw as hoping there was a way around this.

Try removetiledefs; before the addtiledef scripts. So it removes the other style and loads a new.

So basically
addtiledef worldmaptiles.png,levelname,1;
Then for the other
addtiledef pics1.png,levename,0;

That’s all I can think of . . since I had to do that before.

Thanks, but no go. I tried removing custom tiles on the OW level connected to the world map, as well as adding this to the level, just to try and be sure the level’s tiles would reset to default.
addtiledef pics1.png,levelname,0;

When that failed, I disabled the world map’s mapping, just in case setmap was part of the problem. All with no luck :cry:

So you did
addtiledef pics1.png,levelname,0;
. . . You did remember to remove levelname right?
OH THAT’S IT!!! xD I just noticed.
Levelname is the name of the level you use it in. So just remove that. :smiley: So it’s
addtiledef pics1.png,0;

Hopefully this time I got it right . . :slight_smile:

lol, don’t worry, I just used levelname for an example. I’ve tried with and without the proper levels names already. Thanks, though

Damn, thought I had it for sure. :frowning: Then again who would make that mistake :smiley: . . . . . 0.0 lol Anyways, eventually a scripter will get on. Good luck :frowning:

I don’t think it’s a very good idea to mix and match OW and NW styled tilesets on one and the same server.

Agreed, but my worldmap tiles are too complex to try and arrange them into an OW style tileset, lol (as in, too lazy).

But I seem to have got something that works. Instead of just putting the tile definitions on the levels, I made a hidden System NPC that pre-loads stuff. That seemed to do the trick.

Lol, I thought you were already doing that. :stuck_out_tongue:

Ack! This should also be in the Development area!

Agreed, though at the time of post, I wasn’t quite sure, because it was a technical problem, just one I was looking for a way to get around, knowing it was something client related XD