Boost library not in dependencies?

I just tried to compile gserver2 trunk (1110) on Windows with VS2010.
I get 21 errors, seems to be all related to boost header not found.
Not really sure I am suggesting to have boost included in dependencies… suppose only if boost lib is small enough.

Edit 1) No, I am looking at the size now, I don’t want that repeated for each tags and branch!

Edit 2) I seems to see only boost/thread.hpp errors…
Maybe just putting this part in dependencies could be ok?

If you’re not willing to download something as useful as Boost Lib to compile the gserver, perhaps you should just go ahead and DL the precompiled version

Maybe latter, when SourceForge site will work better

hum, just tried to follow your suggestion but I get on: [This make my Internet Explorer go very slow]

Ok, I have 1.45 (taken from on my USB key.
I’ll get a look later.

Boost is too huge to put into the gserver dependencies.

premake is stupid and retarded

premake4 in gserver have a --no-boost option added

Thanks for the hint!
I now see that if I had done:
premake4 --help
I would have seen that there is now a --no-boost option.

Except it does still try to compile with boost… on Windows.

yeah you can build it with no boost. you can also edit the service/Makefile file after you run build_gmake or whatever. in there you can do something like L/pathtoboostlibaries/ then do -lboost_thread. i had to do all this crap on freebsd to make it compile. this is all assuming you install the libraries.

also, if you are on windows, just download the binary. wtf you doing compiling it unless you changed something?

because he wants to

while he may not possess the knowledge that a frequent user such as you do about the inner workings of the gserver or perhaps the level of knowledge about compiling programs or programming than most users on the forum, you sir lack


most people do stuff just cause

ask a dumb question, get a dumb answer


Well, not sure why the define had not gone through with premake.
But manually adding the define, in gserver2 properties (Configuration properties, C/C++, Preprocessor, Preprocessor definitions, Edit) of VS2010, have work fine, after Build/Rebuild solution: 0 errors, 117 warnings.

… maybe I should have manually erased the old .sln file before 're’doing:
build_vs2010 --no-boost --os=windows --platform=x32 --version

___Merged doublepost__________________

oh, the --version was the problem I think, I was expecting that it would make the options, and moreover show the verison… but then I did not realized that it ignored all the others options I had given.

But I guess doing a clean, would have help… I would not have any .sln file, which would have been better.

No it isn’t. It is awesome.

If you have to manually specify the path to your boost libs, you are doing it wrong. How did you install boost? If you built it manually, you will have to do a make install to set up your environment.

You don’t need to specify the OS or platform either.

It’s premakes fault. premake is stupid and retarded. the makefile it generates leaves out boost libraries in FreeBSD.

Oh. It is just an error in the build script. One line fix. In fact, I just fixed it.

yay. also in debian you can just use apt-get install libboost-all-dev to get everything you need.

mindset of majority of debian based OS users