Client and Windows 7

I’m using Windows 7 and Graal is almost unplayable because of it. For those of you wondering I’m using the 64-bit version if that helps diagnose the problem. Anyways, I get an extremely low framerate, probably around 4 - 7 FPS whenever I play and running in compatibility mode for Vista didn’t help. Got any ideas as to why it would be doing this?

It’s not helpful if you don’t mention which version.

Sorry, I just figured that 222 was standard. That’s which version. It does it for the Graal Editor as well.

What kind of processor do you have? I found when I had an i7 graal refused to cooperate(in a timely manner at least).

“AMD Athlon™ 64 x 2 Dual-Core Processor TK-57 (2 CPUs), ~1.9 GHz” as quoted directly from the DirectX Diagnostic Tool.

I’m using Win7. Runs fine.

I also use Windows 7 64-bit and it runs fine, even with recording software running. Your issue is something else other than just Windows 7 it seems

Are other games running properly?

turn off the light effects

Well, after restarting my computer it went back to normal. Though, I’ve noticed that it gets progressively worse the longer my computer is on…

Same.

I have some performance issues in Windows 7, but it’s mostly playable.

Tricxta helped me fix it by having me set Graal to only access a single core instead of multiple cores. Thanks anyways, guys.

In case anyone else wants to muck around with this here’s a tutorial on setting the affinity of any process.
http://www.addictivetips.com/windows-tips/how-to-set-processor-affinity-to-an-application-in-windows/

I’m having some performance issues with Windows 7 and 222, too.

Playing on GTA, there are certain maps that cause the game to come to a crawl. The mess hall, in the mental asylum in Babord is a great example (police department is another). I don’t know if it’s the number of NPCs or what, but I find it really hard to even walk in that room.

I’ve tried changing the affinity, tried running in Windows XP compatibility mode, running as Administrator etc. Not having much luck atm. Will try a few more things.

[updates] Just tried running with a very small window, and everything is smooth. If I stretch the window to a decent size, everything slows down. I’ve turned off Direct3D lighting too.

Running an intel i7, 8gb ram and a GTX 555, so it’s not an old PC or anything.

Windows 98/ME compatibility mode is a lot smoother, but it has an annoying side-effect of making the HUD flash.

Okay, it seems Windows 2000 compat mode is best. Smooth, without the graphical glitches.

Yeah, I forgot to mention that I cannot run in full-screen without lagging on Windows 7 no matter what I do. I’ll try running in Windows 2000 compatibility mode as well.

Edit: Damn, dude. Running in 2000 compatibility as well as setting the processor affinity has given me no problems at all. Thanks.