Gani troubles

Having a fun time trying to use gani’s for the first time.

The first problem is, I make a gani that uses a custom definition on the image in the #P2 slot. Then animate it to walk, which works with the original .png file I used well making it.
The thing is, if I change the #P2 prop to a 2nd .png file(which was made with differn’t pictures placed overtop the 1st png file) it doesn’t load any picture at all. The gani is now invis minus the shadow.

Since both images have the exact same definitions, why can I not switch thru them like hats or body images?

2nd problem is when using gani’s as an animated picture. One attempt worked for me, the other invisible like the first problem. I make a npc, so
setcharani ganiname,1;
dir = 2;

Which worked for the first 3 gani’s. But for the one’s i’m trying now, again it’s invisible. Direction matches the gani and definitions should be right, so i don’t really get it.

showcharacter; isn’t necessarily needed, its only if you want to define an NPC-Player (collision and etc)
setcharprop #P1,param; //maps to sprites with “ATTR1” for the ‘image’
setcharprop #P2,param; //maps to sprites with “ATTR2” for the ‘image’
setcharani gani,param; //most ganis don’t use params, they’re a “1 time set” attribute. Maps to sprites with “PARAM1” as the ‘image’.

Oh right on, didn’t know what that param part of setcharani was for. Anyway, fixed the first gani problem, which was just a naming typo on my part.

The 2nd problem still persists tho. Which still I find strange as there is an npc nearly identical and it works right.

Nvm again I guess, aparently graal can find some gani’s on it’s own in the gani folder, and other times want you to have the gani placed in the same folder as the level.

Blahhh… sorry.