Having Trouble Setting Up Server

I managed to get a server up, but I can’t get the links to work and dontblock doesn’t seem to be cooperating on lights. I tried both clients, redownloaded and upzipped the server (.80) and new client folders, but I haven’t been able to fix the problem.

Ah. Someone else with this strange problem we can’t seem to replicate.
If you’re willing, post one of the problem levels up here so we can use it as a sample of why things may be breaking.

Actually, I’m using .graal levels, would that do it? Urza got the lights working, still can’t get the levels to link…

For future refrence…

  setimg light2.png;
   setcoloreffect 0.5,0.5,0.5,0.9;

doesn’t work properly, instead use:

 if(created || playerenters){
  setimg light2.png;
  setcoloreffect 0.5,0.5,0.5,0.9;

Also, links to .graal files seem to be broken

I suggest the use of the graaltonw converter

It’s a .graal problem, I got a .nw server to work fine.

Then don’t use GRAAL files -.-

Can this be fixed…? The .graal thing, .graal levels not linking on cutom build gservers

Yes, but for sanity’s sake.
Why the hell still wants to use .graal levels is beyond me.
NW levels have a few advantages over .graal,

  1. Editable by Notepad
  2. Theoretical Unlimited NPC-cap (.graal levels have a limit on how many NPCs are on the level)

I’ve used the textconverter program on around 2k+levels. It worked for the most part, but some levels links weren’t changed, which is frustrating because now It’s gonna be trial and error finding the levels with links that didn’t change to .nw

Who knows how many weren’t completely changed. :rolleyes:

Grab a mass text replacer.
Search “.graal” replace with “.nw”

I do. Mainly because I’ve got so many damn levels from 1.39 that I’d have to edit every single warp on every level. :frowning:

Well once you sift it through a Graal->NW converter, it becomes text based. Meaning you could easily run a program to scan through and replace all instances of “.graal” with “.nw”

Hard part is getting a capable mass text replacer. All of mine expired :E

What’s wrong with sed?

Most people on here host servers on windows… Poor bastards, why would anyone want to host anything on a windows machine? ;(

I’m on Windows and use unix commandline tools all the time… >_> I’m used to them from working on !windows though, so that;s probably why I install 'em.