Looks quite like with the listserver


#1

Oh well, as I am using an old verson of GServer (2.3.1)
That would not count as a bug, more like a report.

I have compiled the npc-server as svn trunk (revision 1110).

So I ran the gserver… then the npc-server.

First time I run it did look like:
C:\Users
ormal\PC-SE~1\PCSER~1\trunk\bin>npcserver_d.exe
Connecting to GServer. . .
Connected to GServer!
Sending Login Data. .
Loaded weapon [-gr_movement]
[stop there a big while, so I launched remote control]

Then after a while I saw that the icons for npc-server where flashing in RemoteControl (about 2x by second]. So I look at the server screen:

And now, when I launch it (remote control connected), I get quite the same, but without much time before the repeating messages:

I have 2.4.0 GServer around, waiting to be configured… I’ll give a try.

Oops, just after closing the GServer, I saw a window from Remote Control (I think): Your nc version is not allowed on this server.
NC? that is the npc-server?
That’s a beginning of an explanation.


#2

99% sure that has nothing to do with the listserver.


#3

downsider: master detective


#4

I guarantee if I posted the shit you did Gllt, I would just get flamed. Ily <3


#5

At first I thought this was link to the CSocket thing.
But now, I suppose this is mostly just the nc not allowed here.


#6

it is fixed in the ‘development’ branch, compile that one instead. trunk is very old


#7

With the development branch of npcserver-v1

Compiled it…

on the server:

RC was stably showing npcserver icons… they were empty, but my world is ‘empty’.