My ship hasn't come in...

…Specifically, the one going to Chaotica. There’s a stupid bug where even if the depart time goes to 0, the boat won’t appear, and it will automatically go to the “Arriving in ____” message.

I miss just having the teleporter go to Chaotica…

I thought kalzor fixed that…

It’s never happened to me for some reason. If a staff member is on while this happens, ask them to update the level for you.

Other than that I dunno…I thought kalzor fixed it too ?_?

give all players the ability to update level, incase they run into that kinda bug :slight_smile:

Just keep waiting!

go back to the old way of getting to chaotica. this way is gay

I thought I fixed it too!

Staff doing update level will fix it if it broke again.

Edit: went through and updated them all, should be good for a week or so.

I definitely just waited twenty minutes for nothing…

Well, I never got the ship, but I made it to Chaotica anyway, through sheer dogged determination and a special method I devised to get past that stupid “drowning” thing without the Zorbi Ring. It helps having an old-school knowledge of Graal scripting.

A new problem has arisen, however: I just did the Baddie Castle thing, and I opened the treasure with Jolt Bombs in it, but it didn’t add them to my inventory. Was that supposed to happen… err… not happen?

With Bombs are your selected weapon, press A to cycle through the different types you have.

Awesome. Thanks!