No longer able to run the client...

I have tried searching around, but I can’t seem to find any particular answers that are relevent to my situation. Getting right to it, I can’t seem to get the 2.2.2 version of the Graal client to run at all anymore. I get a couple of errors in succession each time, like these:

And I get similar errors with version 2.3.1:

And, again, with the Graal Editor:

Curiously, I can run without any issues. I don’t suppose there’s a solution to this? My best guess here, based on previous searches, is that Graal isn’t compatible with Windows 8.1, but I don’t seem to have the same problem as anyone else. It’s rather strange that an older version of the client works fine and not a newer one. Worst case scenario is that I’m stuck with, which is a frustrating thought.

It kind of seems virus-like to me. Redownloading may help, but not if you have something actively infecting executable files.

I had graal running fine on 8.1, it’s when I upgraded to 10 that my editor produced similar errors to what you’ve shown. The client still works fine though.

I did some scans and came up with nothing and went ahead and redownloaded the client. After extracting it, I was able to open 2.2.2 up once without error, but after closing out of it and attempting to reopen it, I’m right back to where I started. Subsequent “clean installs” didn’t work on first try, either. However, upon further attempts to open the client, it sometimes does open up and I am able to log in and play, but more often than not it still throws errors in my face and refuses to come up. I have been mostly unsuccessful in getting to the editor, though, as even when I have successfully opened the client, the moment I try to go to “Training” it throws up errors like this one and promptly exits:

On one particular instance, I was able to access “Training”, but was greeted with this oddity:

After which, attempting to press F4 resulted in more errors and it closed itself out. So far, only one attempt was successful where I opened the client, accessed “Training” and was even able to press F4 to get to the editor. Very strange.

I thought I’d post an update on the situation in the event anyone else has my exact problem. Turns out the issue was that I had my system locale set to Japanese. Once I set it back to English, the client and editor have been functioning properly. To think it took this long to figure out something so simple. Bah.

ah is that why I have been having problems? Oh well, VNs > Graal.


Man, what ever happened to Windows 9?

They skipped it. Touhou fans were pissed because they couldn’t the jokes they made about a character that had to do with the number 9 real.

Because of compatibility…
Some things were coded something like: if(startswith(windowsversion,windows 9) -> do stuff.

To avoid problems, they shifted directly to 10.

I really doubt compatibility even occurred to Microsoft considering their track record.…-not-windows-9

Not to mention that Windows is the best OS compatibility wise… Linux and MacOS? You’re kidding.

I frequently hear stories about MacOS updates making already installed programs misbehave. In contrast Windows updates like nothing hapenned.

That article doesn’t exactly reinforce the theory that it was because of version numbers.

Windows is the best OS compatibility wise
before Windows 10 came out, we had to wait for 8.1 because 8 was a buggy piece of shit for compatibility. That’s the track record I’m talking about. Vista was also similar.

Are you talking about drivers or applications? Also, which kind of apps/drivers?

I found that while many steam games bugged, running them in administrator mode took charge of the problem. Apart from that, the backward compatibility menu in .exe files was still present and useful. To me 8 was a disaster mostly because the interface didn’t make sense in a lot of points. DosBox worked… plug and play was working allright. I’ve never owned Windows 8 but from my experience and seeing less experienced users using it without trouble, it doesn’t appear as bad as you make it sound…?

In regards to this thread, wrong system locale could have been set on any iteration of windows. Graal misbehaving was, to my experience, a problem due to my computer’s architecture and not Windows (I set it to use just one of my processor cores and now it works).

Oh trust me, it was bad. I couldn’t get some games from 2000 to 2008 to run on Windows 8.0, and everyone knows the notoriety Vista had for being terrible. This was even with administrator access and experimenting with every setting for compatibility. I’m glad it wasn’t my PC, because using Win8 before the big 8.1 update would have been hell. Just because you didn’t experience it first hand doesn’t mean it didn’t happen.

edit: I’m having a hard time finding sources, but I know Windows 8 had always been the elephant in the room and it wasn’t just because of the new touch controls and start menu.

Operating systems have to sacrifice compatibility with antiquated functionality eventually for the sake of performance and security improvements. Just because something was created in, say, 2008, doesn’t mean it was using 2008 functionality exclusively.

Well, which games?