Problem with RC2


#1

I’m trying to run RC2, but can’t get it to work. It freezes and forces me to kill the process.

Tried re-downloading the GraalReborn package, and still no RC2 works for me.

Any help?
[ATTACH=CONFIG]3930[/ATTACH]

PD: It works when not using graphical menu, but it’s much more simpler and comfortable with it.

___Merged doublepost__________________

After further research it seems to be because I’m running Windows 8.
Is there any way to run it with windows 8?


#2

Here under Linux wine 1.7.38: I get an exception inside gdk:
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x6c36e568).

Backtrace:
=>0 0x6c36e568 in libgdk-win32-2.0-0 (+0x2e568) (0x0033fc08)
1 0x6c36769d in libgdk-win32-2.0-0 (+0x2769c) (0x0033fc28)
2 0x6c341400 in libgdk-win32-2.0-0 (+0x13ff) (0x0033fc48)
3 0x61882cb8 in libgtk-win32-2.0-0 (+0x102cb7) (0x0033fc68)
4 0x61882ceb in libgtk-win32-2.0-0 (+0x102cea) (0x0033fc88)
5 0x61882dc6 in libgtk-win32-2.0-0 (+0x102dc5) (0x0033fc98)
6 0x00431770 in rc2_2.05 (+0x3176f) (0x0033fe60)

___Merged doublepost__________________

Have you search for: “Windows 8 RC2 patch” which links to a site I think I don’t have right to add links to.


#3

I never know what the heck is wrong with that damn program.


#4

Ok, let’s make it simple.
This new version seems to works as well if not better as before for me:
http://s000.tinyupload.com/index.php?file_id=92961419156140139230
I updated files to latest gtk 2 version. It was done by replacing old .dll files with more recent versions from:
http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.24/gtk±bundle_2.24.10-20120208_win32.zip

Keep in mind that for me it is just a login window and a server lister.

I just hope my password is really not there… anymore. :wink:

Edit6) Under Wine, when trying to login to some random server I get a black window taking 99.9% cpu.
Edit7) It works, was because it was decompressed in “T?l?chargements” directory, which is french for Downloads, and the images were not loaded with a path with “?” in it. Where ? is an “e” acute.

Edit 8) So, original version was not loading in wine, new one does.
Please test! If it works, especially under Win8, it would be worth to replace in released client files.


#5

It could be a large number of things, but what you’re describing makes me think it might be missing a resource. Make sure all of your resource files are correct, perhaps try a fresh install of rc2.


#6

Thanks Zartox for helping, but still the RC2 freezes when trying the graphical menu.

I think I’ll update to Win 10 next month. Let’s hope it works there.

___Merged doublepost__________________

I re-installed multiple times RC2.


#7

all rc versions run fine under wine.


#8

Surely not with stable wine: 1.6.2
Running Debian Jessy now with wine (1.6.2-20) and doing the same as in previous message on tying to launch it,
Which version are you using?

To Eroz: Thanks for trying it! Sad it does not work for you.
Yeah… it works for me (both original and mine) under Win 10 32 bits… are you on 32 bits Win 8?
And now by works, means I have started my own gserver on my machine, and use RC2 to show files, etc.


#9

I’m running windows 8 64 bits.
My computer will automatically download and install windows 10 64 bits when it releases.


#10

rest in peace, another brother fell victim to the streets