Unstick Me

Hey guys, since I updated the gserv to 0.14.0, the unstick me function no longer works. It keeps saying wait 30seconds over and over, even if the player has been waiting 30seconds or longer without moving, speaking or taking any actions.

is there a level for unstick me to goto?

Onlinestartlocal, as usual. :stuck_out_tongue:

Noticed this a bit too, figured it was a fluke in one of my systems.

I don’t need to worry – I use a custom unstick me system puts on sunglasses, drives motorcycle out of this thread

What we need is some good solvent.

if (playerenters || playerdies) {
while (true) {
this.wait += 0.05;
if (this.px != playerx || this.py != playery) {
this.wait = 0;
this.px = playerx;
this.py = playery;
sleep 0.05;

if (playerchats && strequals(#c,unstick me) && this.px == playerx && this.py == playery && this.wait > 30) {
setlevel2 onlinestartlocal.nw,30,30;


edit: nevermind, shit’s broken


[code]if(playerenters || playerdies) {
this.time = 0;
while (true) {
if ({playerx,playery} == this.pos) this.time = (this.time + 0.05 < 30) ? this.time + 0.05 : 30;
else this.time = 0;
this.pos = {playerx,playery};
sleep 0.05;

if(playerchats && (strequals(#c,unstick me) || strequals(#c,unstuck me))) {
if(this.time == 30) {
setplayerprop #c,MMM, MOAR WARPZ!;
setlevel2 onlinestartlocal.nw,30,30;
} else {
setplayerprop #c,Chill out, Bitch! Wait the 30 damn seconds!;

You sure like to cough a lot.
Although wouldn’t the part if (this.time == 30) { in the secound part, why the ==. doesn’t that mean exact so you would have to say unstick me at exactly 30 secounds?


Also, this.time = (this.time + 0.05 < 30) ? this.time + 0.05 : 30; in Beholder’s script prevents it from going over 30, so his is right.

Wouldn’t those scripts execute when the player first logged on the server? and if they got stuck, their X&Y would be different from them. Need some sort of triggeraction perhaps?


unstick me is broken in 0.14.0. I fixed it in SVN a while ago. If anybody has an SVN version, why not test it to see if I complete fixed it?

You fixed it my hero. Alteast it worked on the server I was hosting and that were built fresh from SVN >:O

Just disable everything default and make it yourself :stuck_out_tongue: GO BEHOLDER GO!

Thanks for the responses, guys. Also, I should start putting these in the bug report section >.>